about summary refs log tree commit diff
path: root/fun/gemma/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'fun/gemma/default.nix')
-rw-r--r--fun/gemma/default.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/fun/gemma/default.nix b/fun/gemma/default.nix
index 4a26005852..339b86d269 100644
--- a/fun/gemma/default.nix
+++ b/fun/gemma/default.nix
@@ -1,8 +1,7 @@
-{ depot, pkgs, ... }:
+{ depot, ... }:
 
 let
-  inherit (pkgs) cacert iana-etc libredirect stdenv runCommandNoCC writeText;
-  elmPackages = depot.third_party.elmPackages_0_18;
+  inherit (depot.third_party.elmPackages_0_18) cacert iana-etc libredirect stdenv runCommand writeText elmPackages;
 
   frontend = stdenv.mkDerivation {
     name = "gemma-frontend.html";
@@ -28,7 +27,7 @@ let
 
   injectFrontend = writeText "gemma-frontend.lisp" ''
     (in-package :gemma)
-    (setq *static-file-location* "${runCommandNoCC "frontend" {} ''
+    (setq *static-file-location* "${runCommand "frontend" {} ''
       mkdir -p $out
       cp ${frontend} $out/index.html
     ''}/")