about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 4c54d15646..38de1be0de 100644
--- a/default.nix
+++ b/default.nix
@@ -70,4 +70,13 @@ in fix(self: {
     runCommand
     symlinkJoin
     writeText;
-})
+}
+
+# These packages must be exposed for compatibility with buildGo.
+#
+# Despite buildGo being tracked in this tree, I want it to be possible
+# for external users to import it with the default nixpkgs layout.
+// {
+  inherit (self.third_party) go ripgrep;
+}
+)