summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000000..a95d0e0f4d
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,17 @@
+# This file sets up the top-level package set by merging all local
+# packages into the nixpkgs top-level.
+
+let
+  localPkgs = super: pkgs: {
+    tazjin.tazblog = import ./services/tazblog { inherit pkgs; };
+  };
+
+  # TODO(tazjin): It might be preferable to pin a specific commit of
+  # nixpkgs, but for now the assumption will be that a single release
+  # channel is reasonably stable.
+  nixpkgsVersion = "nixos-19.03";
+  nixpkgs = "https://github.com/NixOS/nixpkgs-channels/archive/${nixpkgsVersion}.tar.gz";
+
+in import (builtins.fetchTarball nixpkgs) {
+    overlays = [ localPkgs ];
+}