about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 866b3fa6bf..941110b222 100644
--- a/default.nix
+++ b/default.nix
@@ -79,13 +79,14 @@ let
       # Include the node itself if it is eligible.
       (if eligible node then [ node ] else [])
       # Include eligible children of the node
-      ++ concatMap gather (attrValues node)
+      ++ concatMap gather (map (attr: node."${attr}") node.__readTreeChildren)
       # Include specified sub-targets of the node
       ++ filter eligible (map
            (k: (node."${k}" or {}) // {
              # Keep the same tree location, but explicitly mark this
              # node as a subtarget.
              __readTree = node.__readTree;
+             __readTreeChildren = [];
              __subtarget = k;
            })
            (node.meta.targets or []))