about summary refs log tree commit diff
path: root/corp/rih/backend/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'corp/rih/backend/default.nix')
-rw-r--r--corp/rih/backend/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/corp/rih/backend/default.nix b/corp/rih/backend/default.nix
new file mode 100644
index 0000000000..802479e509
--- /dev/null
+++ b/corp/rih/backend/default.nix
@@ -0,0 +1,16 @@
+{ depot, pkgs, ... }:
+
+depot.nix.readTree.drvTargets rec {
+  binary = depot.third_party.naersk.buildPackage {
+    src = ./.;
+  };
+
+  image = pkgs.dockerTools.buildLayeredImage {
+    name = "rih-backend";
+    config.Cmd = [ "${binary}/bin/rih-backend" ];
+
+    contents = [
+      binary
+    ];
+  };
+}