about summary refs log tree commit diff
path: root/corepkgs/buildenv.nix
diff options
context:
space:
mode:
Diffstat (limited to 'corepkgs/buildenv.nix')
-rw-r--r--corepkgs/buildenv.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/corepkgs/buildenv.nix b/corepkgs/buildenv.nix
new file mode 100644
index 000000000000..6e2bee10b1e7
--- /dev/null
+++ b/corepkgs/buildenv.nix
@@ -0,0 +1,21 @@
+with import <nix/config.nix>;
+
+{ system, derivations, manifest }:
+
+derivation { 
+  name = "user-environment";
+  system = system;
+  builder = perl;
+  args = [ "-w" ./buildenv.pl ];
+  
+  manifest = manifest;
+
+  # !!! grmbl, need structured data for passing this in a clean way.
+  paths = derivations;
+  active = map (x: if x ? meta && x.meta ? active then x.meta.active else "true") derivations;
+  priority = map (x: if x ? meta && x.meta ? priority then x.meta.priority else "5") derivations;
+
+  # Building user environments remotely just causes huge amounts of
+  # network traffic, so don't do that.
+  preferLocalBuild = true;
+}