about summary refs log tree commit diff
path: root/blog/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'blog/default.nix')
-rw-r--r--blog/default.nix21
1 files changed, 0 insertions, 21 deletions
diff --git a/blog/default.nix b/blog/default.nix
deleted file mode 100644
index fd35570a322a..000000000000
--- a/blog/default.nix
+++ /dev/null
@@ -1,21 +0,0 @@
-{ pkgs, depot, briefcase, ... }:
-
-let
-  injections = pkgs.writeText "injections.lisp" ''
-    (in-package #:server)
-    (setq *path-to-posts* "${./posts}")
-    (setq *pandoc-bin* "${pkgs.pandoc}/bin/pandoc")
-    (setq *html-template* "${./src/index.html}")
-  '';
-in depot.nix.buildLisp.program {
-  name = "server";
-  deps = with depot.third_party.lisp; with briefcase.third_party.lisp; [
-    hunchentoot
-    cl-arrows
-    cl-ppcre
-  ];
-  srcs = [
-    ./src/server.lisp
-    injections
-  ];
-}