about summary refs log tree commit diff
path: root/web/tvl/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2022-09-26T17·33+0200
committersterni <sternenseemann@systemli.org>2022-09-28T08·02+0000
commit0c178a0ef61d2f5f4d6169c7a951663c62509cd7 (patch)
tree08d4b97e5d423f9624211f92700e8bd1cf27fcbc /web/tvl/default.nix
parentf40283e0985b5e16a7d67e018a16b0d52f09b90c (diff)
chore(3p/sources): Bump channels & overlays r/4980
Upstream nixpkgs removed a lot of aliases this time, so we needed to do
the following transformations. It's a real shame that aliases only
really become discoverable easily when they are removed.

* runCommandNoCC -> runCommand
* gmailieer -> lieer
  We also need to work around the fact that home-manager hasn't catched
  on to this rename.
* mysql -> mariadb
* pkgconfig -> pkg-config
  This also affects our Nix fork which needs to be bumped.
* prometheus_client -> prometheus-client
* rxvt_unicode -> rxvt-unicode-unwrapped
* nix-review -> nixpkgs-review
* oauth2_proxy -> oauth2-proxy

Additionally, some Go-related builders decided to drop support for
passing the sha256 hash in directly, so we need to use the generic hash
arguments.

Change-Id: I84aaa225ef18962937f8616a9ff064822f0d5dc3
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6792
Autosubmit: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Reviewed-by: flokli <flokli@flokli.de>
Reviewed-by: tazjin <tazjin@tvl.su>
Reviewed-by: wpcarro <wpcarro@gmail.com>
Diffstat (limited to 'web/tvl/default.nix')
-rw-r--r--web/tvl/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/web/tvl/default.nix b/web/tvl/default.nix
index 262be54c0e..044d2791d6 100644
--- a/web/tvl/default.nix
+++ b/web/tvl/default.nix
@@ -4,7 +4,7 @@ with depot.nix.yants;
 
 let
   inherit (builtins) filter;
-  inherit (pkgs) graphviz runCommandNoCC writeText;
+  inherit (pkgs) graphviz runCommand writeText;
   inherit (depot.web) atom-feed blog tvl;
 
   listPosts = defun [ (list blog.post) string ] (posts:
@@ -16,7 +16,7 @@ let
       (map (p: "cp ${blog.renderPost tvl.blog.config p} $out/blog/${p.key}.html") posts)
   );
 
-  tvlGraph = runCommandNoCC "tvl.svg"
+  tvlGraph = runCommand "tvl.svg"
     {
       nativeBuildInputs = with pkgs; [ fontconfig freetype cairo jetbrains-mono ];
     } ''
@@ -123,7 +123,7 @@ let
     '';
   };
 in
-runCommandNoCC "website" { } ''
+runCommand "website" { } ''
   mkdir -p $out/blog
   cp ${homepage} $out/index.html
   ${postRenderingCommands tvl.blog.posts}