about summary refs log tree commit diff
path: root/web/tvixbolt/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@tvl.su>2024-02-23T08·00+0300
committerclbot <clbot@tvl.fyi>2024-02-23T08·08+0000
commit782cfa9e3372d0cfe13471597968d58deb181e71 (patch)
tree590d43f902e8ce560a26781732df87105a19b9e9 /web/tvixbolt/Cargo.toml
parent91d5745c3dbb3eb118be969a80e0608794b0e59d (diff)
chore(tvixbolt): move from //corp to //web r/7595
Assigning copyright to the TVL community (whatever that is), and
adding AGPL-3.0-or-later license.

I also cleaned up some of the stuff on the landing page.

Change-Id: I4dbca19406e00e5105fed50e8fb64e0fcca23e3a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11013
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'web/tvixbolt/Cargo.toml')
-rw-r--r--web/tvixbolt/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/web/tvixbolt/Cargo.toml b/web/tvixbolt/Cargo.toml
new file mode 100644
index 0000000000..ce5ffb90e3
--- /dev/null
+++ b/web/tvixbolt/Cargo.toml
@@ -0,0 +1,26 @@
+[package]
+name = "tvixbolt"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+yew = "0.19.3"
+yew-router = "0.16"
+codemap = "0.1.3"
+serde_urlencoded = "*" # pinned by yew
+rnix = "0.11.0"
+
+# needs to be in sync with nixpkgs
+wasm-bindgen = "= 0.2.91"
+
+[dependencies.tvix-eval]
+path = "../../tvix/eval"
+default-features = false
+
+[dependencies.serde]
+version = "*" # pinned by yew
+features = [ "derive" ]
+
+[dependencies.web-sys]
+version = "*" # pinned by yew
+features = [ "HtmlDetailsElement" ]