about summary refs log tree commit diff
path: root/web/panettone/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2021-01-14T01·07+0100
committersterni <sternenseemann@systemli.org>2021-01-25T21·02+0000
commit82e07fc046cff2151f9d18a003c6331202d58c8b (patch)
treec528dde5bed5899aa53fbc7bba761bf8abb23969 /web/panettone/default.nix
parent7e408c874ac9b84f62bd48a3a6f2b57bae866d29 (diff)
feat(panettone): render a subset of markdown in issue subjects r/2144
This is achieved by implementing a simple markdown renderer in CL which
has the following limitations:

* Only supports inline `code`, *emphasize 1*, _emphasize 2_ and
  ~~strikethrough~~.
* Does not support nested markup.

This allows for a relatively simple renderer which doesn't need to parse
markdown into a in-memory data structure first. The rendered result is
directly written to a stream to integrate well with cl-who which is also
reused for rendering tags and xml-escaping strings.

Fixes #90.

Change-Id: Ice88ed770b1fab6365f3b93e8663e25077befa0b
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2389
Tested-by: BuildkiteCI
Reviewed-by: glittershark <grfn@gws.fyi>
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'web/panettone/default.nix')
-rw-r--r--web/panettone/default.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/web/panettone/default.nix b/web/panettone/default.nix
index 8d112901ec..4238af804a 100644
--- a/web/panettone/default.nix
+++ b/web/panettone/default.nix
@@ -24,6 +24,7 @@ depot.nix.buildLisp.program {
     ./src/packages.lisp
     ./src/util.lisp
     ./src/css.lisp
+    ./src/inline-markdown.lisp
     ./src/authentication.lisp
     ./src/model.lisp
     ./src/irc.lisp
@@ -38,6 +39,7 @@ depot.nix.buildLisp.program {
     srcs = [
       ./test/package.lisp
       ./test/model_test.lisp
+      ./test/inline-markdown_test.lisp
     ];
 
     expression = "(fiveam:run!)";