about summary refs log tree commit diff
path: root/web/bubblegum/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-01-30T16·06+0300
committertazjin <tazjin@tvl.su>2022-01-31T16·11+0000
commitaa122cbae78ce97d60c0c98ba14df753d97e40b1 (patch)
tree12b98d85c4b18fe870feb26de70db9ba61837bd7 /web/bubblegum/default.nix
parent2d10d60fac0fd00a71b65cfdcb9fba0477b2086c (diff)
style: format entire depot with nixpkgs-fmt r/3723
This CL can be used to compare the style of nixpkgs-fmt against other
formatters (nixpkgs, alejandra).

Change-Id: I87c6abff6bcb546b02ead15ad0405f81e01b6d9e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4397
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Reviewed-by: wpcarro <wpcarro@gmail.com>
Reviewed-by: Profpatsch <mail@profpatsch.de>
Reviewed-by: kanepyork <rikingcoding@gmail.com>
Reviewed-by: tazjin <tazjin@tvl.su>
Reviewed-by: cynthia <cynthia@tvl.fyi>
Reviewed-by: edef <edef@edef.eu>
Reviewed-by: eta <tvl@eta.st>
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'web/bubblegum/default.nix')
-rw-r--r--web/bubblegum/default.nix66
1 files changed, 41 insertions, 25 deletions
diff --git a/web/bubblegum/default.nix b/web/bubblegum/default.nix
index 1fbe544bce..528d73032b 100644
--- a/web/bubblegum/default.nix
+++ b/web/bubblegum/default.nix
@@ -134,20 +134,23 @@ let
           code = statusCodes."${statusArg}" or null;
           line = statusArg;
         } else {
-          code = null; line = null;
+          code = null;
+          line = null;
         };
       renderedHeaders = lib.concatStrings
         (lib.mapAttrsToList (n: v: "${n}: ${toString v}\r\n") headers);
-      internalError = msg: respond 500 {
-        Content-type = "text/plain";
-      } "bubblegum error: ${msg}";
+      internalError = msg: respond 500
+        {
+          Content-type = "text/plain";
+        } "bubblegum error: ${msg}";
       body = builtins.tryEval bodyArg;
     in
-      if status.code == null || status.line == null
-      then internalError "Invalid status ${lib.generators.toPretty {} statusArg}."
-      else if !body.success
-      then internalError "Unknown evaluation error in user code"
-      else lib.concatStrings [
+    if status.code == null || status.line == null
+    then internalError "Invalid status ${lib.generators.toPretty {} statusArg}."
+    else if !body.success
+    then internalError "Unknown evaluation error in user code"
+    else
+      lib.concatStrings [
         "Status: ${toString status.code} ${status.line}\r\n"
         renderedHeaders
         "\r\n"
@@ -169,9 +172,9 @@ let
     let
       p = builtins.getEnv "PATH_INFO";
     in
-      if builtins.stringLength p == 0
-      then "/"
-      else p;
+    if builtins.stringLength p == 0
+    then "/"
+    else p;
 
   /* Helper function which converts a path from the
      root of the CGI script (i. e. something which
@@ -187,12 +190,13 @@ let
     else "${scriptName}/${path}";
 
   bins = getBins pkgs.coreutils [ "env" "tee" "cat" "printf" "chmod" ]
-      // getBins nint [ "nint" ];
+    // getBins nint [ "nint" ];
 
   /* Type: args -> either path derivation string -> derivation
   */
   writeCGI =
-    { # if given sets the `PATH` to search for `nix-instantiate`
+    {
+      # if given sets the `PATH` to search for `nix-instantiate`
       # Useful when using for example thttpd which unsets `PATH`
       # in the CGI environment.
       binPath ? ""
@@ -202,7 +206,8 @@ let
     , name ? null
     , ...
     }@args:
-    input: let
+    input:
+    let
       drvName =
         if builtins.isString input || args ? name
         then args.name
@@ -227,20 +232,31 @@ let
         # always pass depot so scripts can use this library
         "--arg depot '(import ${minimalDepot} {})'"
       ]);
-    in runExecline.local drvName {} [
-      "importas" "out" "out"
-      "pipeline" [
-        "foreground" [
-          "if" [ bins.printf "%s\n" shebang ]
+    in
+    runExecline.local drvName { } [
+      "importas"
+      "out"
+      "out"
+      "pipeline"
+      [
+        "foreground"
+        [
+          "if"
+          [ bins.printf "%s\n" shebang ]
         ]
-        "if" [ bins.cat script ]
+        "if"
+        [ bins.cat script ]
       ]
-      "if" [ bins.tee "$out" ]
-      "if" [ bins.chmod "+x" "$out" ]
-      "exit" "0"
+      "if"
+      [ bins.tee "$out" ]
+      "if"
+      [ bins.chmod "+x" "$out" ]
+      "exit"
+      "0"
     ];
 
-in {
+in
+{
   inherit
     respond
     pathInfo