about summary refs log tree commit diff
path: root/web/bubblegum/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2021-09-09T16·26+0200
committersterni <sternenseemann@systemli.org>2021-09-10T11·08+0000
commit318d10e60875ef69132651668a249de75730d2ba (patch)
treeaa3afe8c249edf6ab398657895afbfd271ef91b1 /web/bubblegum/default.nix
parent5d5fb4e6a1b3baee89d89f17ebc11bc19888c59a (diff)
chore(nint): move from //users/sterni to //nix r/2833
Since //web/bubblegum depends on nint, we need to move it to a non user
directory to conform with the policy established via cl/3434.
Note that this likely doesn't mean greater stability (which isn't
really implied in depot anyways), since I still would like to use a more
elaborate calling convention to allow for additional useful features.

Change-Id: I616f905d8df13e3363674aab69a797b0d39fdd79
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3506
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'web/bubblegum/default.nix')
-rw-r--r--web/bubblegum/default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/web/bubblegum/default.nix b/web/bubblegum/default.nix
index 0ad541390b..2db6f04204 100644
--- a/web/bubblegum/default.nix
+++ b/web/bubblegum/default.nix
@@ -7,6 +7,7 @@ let
     getBins
     utils
     sparseTree
+    nint
     ;
 
   minimalDepot = sparseTree depot.path [
@@ -186,7 +187,7 @@ let
     else "${scriptName}/${path}";
 
   bins = getBins pkgs.coreutils [ "env" "tee" "cat" "printf" "chmod" ]
-      // getBins depot.users.sterni.nint [ "nint" ];
+      // getBins nint [ "nint" ];
 
   /* Type: args -> either path derivation string -> derivation
   */