about summary refs log tree commit diff
path: root/users/tazjin/nixos/frog/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-14T10·36+0200
committertazjin <mail@tazj.in>2021-04-14T11·20+0000
commitdd42891ab0ae7fbef3b6ed10f065321cef3fdb61 (patch)
treeaf365e87449570afff3d6b27b096f34e222abe5c /users/tazjin/nixos/frog/default.nix
parent8f59300ae815247148b501d99858bce3ec65fe7f (diff)
refactor(tazjin/emacs): Install google-c-style by default r/2507
It is easier to do the inverse of this solution: Filter out the
package on the machines that get it from elsewhere.

Change-Id: I2abe112e4e38822d0fc7a47ea0bcedec1e0a96e3
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3010
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'users/tazjin/nixos/frog/default.nix')
-rw-r--r--users/tazjin/nixos/frog/default.nix10
1 files changed, 2 insertions, 8 deletions
diff --git a/users/tazjin/nixos/frog/default.nix b/users/tazjin/nixos/frog/default.nix
index 0b74d3e575..05df8caab5 100644
--- a/users/tazjin/nixos/frog/default.nix
+++ b/users/tazjin/nixos/frog/default.nix
@@ -3,12 +3,6 @@
 config: let
   inherit (depot.third_party) lieer;
 
-  # add google-c-style here because other machines get it from, eh,
-  # elsewhere.
-  frogEmacs = (depot.users.tazjin.emacs.overrideEmacs(epkgs: epkgs ++ [
-    pkgs.emacsPackages.google-c-style
-  ]));
-
   quasselClient = pkgs.quassel.override {
     client = true;
     enableDaemon = false;
@@ -182,7 +176,7 @@ in lib.fix(self: {
 
     windowManager.session = lib.singleton {
       name = "exwm";
-      start = "${frogEmacs}/bin/tazjins-emacs";
+      start = "${depot.users.tazjin.emacs}/bin/tazjins-emacs";
     };
   };
 
@@ -217,7 +211,6 @@ in lib.fix(self: {
   environment.systemPackages =
     # programs from the depot
     (with depot; [
-      frogEmacs
       fun.idual.script
       fun.uggc
       lieer
@@ -225,6 +218,7 @@ in lib.fix(self: {
       quasselClient
       third_party.git
       tools.nsfv-setup
+      users.tazjin.emacs
     ]) ++
 
     # programs from nixpkgs