about summary refs log tree commit diff
path: root/users/tazjin/nixos/frog/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-19T21·58+0200
committertazjin <mail@tazj.in>2021-04-20T10·43+0000
commit5f19e8e6a73f7d76fa4bb62036891e824b64b515 (patch)
treed108bb45411c1757bc2dc22f5b7522edacab00f6 /users/tazjin/nixos/frog/default.nix
parentd485ebf01a7e554bd8d43fb17e4a19d6145a6a6b (diff)
refactor(ops/nixos): Ensure that pkgs == depot.third_party.nixpkgs r/2527
This is currently done ad-hoc in a bunch of our systems, but we should
just do it centrally.

The commit message is a bit of a lie, as this doesn't yet update
grfn's systems.

Change-Id: Ic771c1a1da78ec5de9cffbf94c296dce5e11fd84
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3047
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'users/tazjin/nixos/frog/default.nix')
-rw-r--r--users/tazjin/nixos/frog/default.nix7
1 files changed, 0 insertions, 7 deletions
diff --git a/users/tazjin/nixos/frog/default.nix b/users/tazjin/nixos/frog/default.nix
index 05df8caab5..896c7e8c97 100644
--- a/users/tazjin/nixos/frog/default.nix
+++ b/users/tazjin/nixos/frog/default.nix
@@ -61,17 +61,10 @@ in lib.fix(self: {
 
   nix = {
     maxJobs = 48;
-    nixPath = [
-      "depot=/depot"
-      "nixpkgs=${pkgs.path}"
-    ];
-
     binaryCaches = ["ssh://nix-ssh@whitby.tvl.fyi"];
     binaryCachePublicKeys = ["cache.tvl.fyi:fd+9d1ceCPvDX/xVhcfv8nAa6njEhAGAEe+oGJDEeoc="];
   };
 
-  nixpkgs.pkgs = pkgs;
-
   networking = {
     hostName = "frog";
     useDHCP = true;