about summary refs log tree commit diff
path: root/users/tazjin/german-string/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2024-08-16T10·35+0300
committerclbot <clbot@tvl.fyi>2024-08-19T11·42+0000
commitef75a6300b5ae659b26587cbae58e2ff9ffb97bf (patch)
tree4b84b236d01e5fe0aebc771b80bdfcb1f7ae85b1 /users/tazjin/german-string/Cargo.toml
parentabff828ccc6a7d8478b624277737cd9c6bb9c901 (diff)
feat(tazjin/german-string): init initial representation r/8522
This adds an initial implementation of the so-called "German Strings" in Rust.

https://cedardb.com/blog/german_strings/

This implementation is *far from* complete, the only thing that can be done
right now is construct a string, and even that I'm not fully happy with.

Change-Id: I2697932a0ef373be76ffd14d59677493a5783b58
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12234
Autosubmit: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'users/tazjin/german-string/Cargo.toml')
-rw-r--r--users/tazjin/german-string/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/users/tazjin/german-string/Cargo.toml b/users/tazjin/german-string/Cargo.toml
new file mode 100644
index 000000000000..90462e964839
--- /dev/null
+++ b/users/tazjin/german-string/Cargo.toml
@@ -0,0 +1,6 @@
+[package]
+name = "german-string"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]