about summary refs log tree commit diff
path: root/users/tazjin/finito/finito-postgres/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-06-30T03·35+0100
committerVincent Ambo <mail@tazj.in>2020-06-30T03·35+0100
commit9e7b81391d016d98ef9b5f0c1f3405bdec31133c (patch)
tree5310a4a669f6f163df1969bdc44a2b6198363e84 /users/tazjin/finito/finito-postgres/Cargo.toml
parent0380841eb11f6cb200081295107fadbca928bc06 (diff)
parentb7481172252d6f00546e94534b05d011b4105843 (diff)
feat(tazjin/finito): Check in my old Rust state-machine library r/1136
I dug through my archives for this and found a version that, while
unfortunately not the latest implementation, is close enough to the
real thing to show off what Finito did.

This is a Postgres-backed state-machine library for complex
application logic. I wrote this originally for a work purpose in a
previous life, but have always wanted to apply it elsewhere, too.

git-subtree-dir: users/tazjin/finito
git-subtree-mainline: 0380841eb11f6cb200081295107fadbca928bc06
git-subtree-split: b7481172252d6f00546e94534b05d011b4105843
Change-Id: I0de02d6258568447a14870f1a533812a67127763
Diffstat (limited to 'users/tazjin/finito/finito-postgres/Cargo.toml')
-rw-r--r--users/tazjin/finito/finito-postgres/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/users/tazjin/finito/finito-postgres/Cargo.toml b/users/tazjin/finito/finito-postgres/Cargo.toml
new file mode 100644
index 0000000000..dd8d1d0003
--- /dev/null
+++ b/users/tazjin/finito/finito-postgres/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "finito-postgres"
+version = "0.1.0"
+authors = ["Vincent Ambo <mail@tazj.in>"]
+
+[dependencies]
+chrono = "0.4"
+postgres-derive = "0.3"
+serde = "1.0"
+serde_json = "1.0"
+r2d2_postgres = "0.14"
+
+[dependencies.postgres]
+version = "0.15"
+features = [ "with-uuid", "with-chrono", "with-serde_json" ]
+
+[dependencies.uuid]
+version = "0.5"
+features = [ "v4" ]
+
+[dependencies.finito]
+path = "../finito-core"
+
+[dev-dependencies.finito-door]
+path = "../finito-door"