about summary refs log tree commit diff
path: root/users/multi/whitby/home-manager.nix
diff options
context:
space:
mode:
authormulti <depot@in-addr.xyz>2020-11-22T15·16+0000
committermulti <depot@in-addr.xyz>2020-11-22T19·48+0000
commit9d6d945f524c06836c1292b3f9ab862521e32b1a (patch)
tree49a4d4e9ed016d8430ae9232ce73d0e107072fb0 /users/multi/whitby/home-manager.nix
parent1e43982c925a5845cef1cf996aef6301e8b37493 (diff)
refactor(users/multi/whitby): use the depot's own source location attribute. r/1897
The depot knows where it is, not because it knows where it isn't, but
because it does an "import ./." at the top level and then makes this
path value available in the attrset passed to the rest of the tree.

My home-manager config on whitby previously involved manual
specification of the depot checkout location on whitby, however this
isn't necessary when the depot can already magically tell us where it
is.

Change-Id: I68577c8ef2cda6ba5bc46cf8f4821aac021c8066
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2122
Tested-by: BuildkiteCI
Reviewed-by: multi <depot@in-addr.xyz>
Diffstat (limited to 'users/multi/whitby/home-manager.nix')
-rw-r--r--users/multi/whitby/home-manager.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/users/multi/whitby/home-manager.nix b/users/multi/whitby/home-manager.nix
index 18deeb4b5a..c034d83f51 100644
--- a/users/multi/whitby/home-manager.nix
+++ b/users/multi/whitby/home-manager.nix
@@ -4,7 +4,6 @@ let
   depot = import <depot> {};
   pkgs = import <nixpkgs> {};
 
-  depotPath = depot.users.multi.whitby.depot;
 in
 
 {
@@ -46,8 +45,8 @@ in
   home.sessionVariables = {
     NIX_PATH =
       "nixpkgs=${depot.third_party.nixpkgsSrc}:" +
-      "depot=${depotPath}";
-    HOME_MANAGER_CONFIG = "${depotPath}/users/multi/whitby/home-manager.nix";
+      "depot=${depot.depotPath}";
+    HOME_MANAGER_CONFIG = "${depot.depotPath}/users/multi/whitby/home-manager.nix";
     EDITOR = "vim";
   };