about summary refs log tree commit diff
path: root/users/multi/home/configs/whitby.nix
diff options
context:
space:
mode:
authormulti <depot@in-addr.xyz>2020-11-22T19·59+0000
committermulti <depot@in-addr.xyz>2020-11-22T20·29+0000
commitba9fb4e1123883ffc2410d11146cb63a5aa7841d (patch)
treea7c4425ac28a60de6e7c9b0bc96127cf62f08a00 /users/multi/home/configs/whitby.nix
parent7ff2142f1946be1c9b0182c34602e7697b4272f7 (diff)
fix(users/multi/home): use local depot checkout. r/1900
This reverts 1478317d149539d74fa4bad8414658fb7119ea07.

Using depot.depotPath in my home-manager configuration results in my
NIX_PATH and home-manager config file path being pointed at a copy of
the depot in the nix store, which makes building from my local depot
checkout a bit cumbersome.

Change-Id: Ib687d3e8147cb32df071d3c19a5300294ea62c0c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2130
Tested-by: BuildkiteCI
Reviewed-by: multi <depot@in-addr.xyz>
Diffstat (limited to 'users/multi/home/configs/whitby.nix')
-rw-r--r--users/multi/home/configs/whitby.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/users/multi/home/configs/whitby.nix b/users/multi/home/configs/whitby.nix
index bd647cf604..90ed1e470f 100644
--- a/users/multi/home/configs/whitby.nix
+++ b/users/multi/home/configs/whitby.nix
@@ -2,6 +2,10 @@
 
 let
   nixpkgs = import pkgs.nixpkgsSrc {};
+
+  # use the depot checkout in my home directory, to make hacking around easier,
+  # instead of the depot checkout sitting in the nix stores
+  depotPath = "/home/multi/depot";
 in
 
 {
@@ -43,8 +47,8 @@ in
   home.sessionVariables = {
     NIX_PATH =
       "nixpkgs=${pkgs.nixpkgsSrc}:" +
-      "depot=${depot.depotPath}";
-    HOME_MANAGER_CONFIG = "${depot.depotPath}/users/multi/home/home-manager.nix";
+      "depot=${depotPath}";
+    HOME_MANAGER_CONFIG = "${depotPath}/users/multi/home/home-manager.nix";
     EDITOR = "vim";
   };