about summary refs log tree commit diff
path: root/users/grfn/xanthous/server/shell.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2021-11-07T19·24-0500
committergrfn <grfn@gws.fyi>2021-11-07T21·05+0000
commit94be8ad755782faabcbaeef4bd6ae484602a54ee (patch)
tree0b2e777042bd0274e128d67220eccbcbc6265ce2 /users/grfn/xanthous/server/shell.nix
parent9b6497e5da2c29bfc109a62390071c94684e78d5 (diff)
feat(gs/xanthous): Add SSH server application r/3015
Add the start of an ssh-compatible server application for playing
Xanthous over ssh. The idea here is that the user can ssh with whatever
username they like (defaulting obviously to their login username) and
then that gets passed as the --name flag to xanthous as they play.

Change-Id: I39eec288ac8e22a165e859479888d78158a58818
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3806
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'users/grfn/xanthous/server/shell.nix')
-rw-r--r--users/grfn/xanthous/server/shell.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/users/grfn/xanthous/server/shell.nix b/users/grfn/xanthous/server/shell.nix
new file mode 100644
index 0000000000..a6747175f1
--- /dev/null
+++ b/users/grfn/xanthous/server/shell.nix
@@ -0,0 +1,11 @@
+let
+  depot = import ../../../.. {};
+  pkgs = depot.third_party.nixpkgs;
+in
+
+pkgs.mkShell {
+  buildInputs = with pkgs; [
+    rustup
+    rust-analyzer
+  ];
+}