about summary refs log tree commit diff
path: root/users/grfn/xanthous/pkg.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2021-11-08T02·33-0500
committergrfn <grfn@gws.fyi>2021-11-08T15·29+0000
commit5b4c4f070187e051049afd8e458793163b4919bb (patch)
treefcd18d9aad6d657634eabe067d743f7b11bfe45c /users/grfn/xanthous/pkg.nix
parent875ef0a605c298e3033ef950119092d09e21f306 (diff)
feat(gs/xanthous): Enable tasty-rerun r/3026
Rerunning only failed tests is nice! To use this, run `cabal new-run
test -- --rerun`

Change-Id: I9dc4d69749c3e3d5ba8d1661a2fdf73e49cd8ad5
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3816
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'users/grfn/xanthous/pkg.nix')
-rw-r--r--users/grfn/xanthous/pkg.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/users/grfn/xanthous/pkg.nix b/users/grfn/xanthous/pkg.nix
index 020fa18266..0f0dbfc982 100644
--- a/users/grfn/xanthous/pkg.nix
+++ b/users/grfn/xanthous/pkg.nix
@@ -10,8 +10,8 @@
 , quickcheck-text, random, random-extras, random-fu, random-source
 , Rasterific, raw-strings-qq, reflection, semigroupoids, semigroups
 , splitmix, stache, streams, tasty, tasty-hunit, tasty-quickcheck
-, text, text-zipper, tomland, transformers, vector, vty, witherable
-, yaml, zlib
+, tasty-rerun, text, text-zipper, tomland, transformers, vector
+, vty, witherable, yaml, zlib
 }:
 mkDerivation {
   pname = "xanthous";
@@ -57,8 +57,8 @@ mkDerivation {
     quickcheck-instances quickcheck-text random random-extras random-fu
     random-source Rasterific raw-strings-qq reflection semigroupoids
     semigroups splitmix stache streams tasty tasty-hunit
-    tasty-quickcheck text text-zipper tomland transformers vector vty
-    witherable yaml zlib
+    tasty-quickcheck tasty-rerun text text-zipper tomland transformers
+    vector vty witherable yaml zlib
   ];
   benchmarkHaskellDepends = [
     aeson array async base bifunctors brick checkers classy-prelude