about summary refs log tree commit diff
path: root/users/grfn/xanthous/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-01-30T16·06+0300
committertazjin <tazjin@tvl.su>2022-01-31T16·11+0000
commitaa122cbae78ce97d60c0c98ba14df753d97e40b1 (patch)
tree12b98d85c4b18fe870feb26de70db9ba61837bd7 /users/grfn/xanthous/default.nix
parent2d10d60fac0fd00a71b65cfdcb9fba0477b2086c (diff)
style: format entire depot with nixpkgs-fmt r/3723
This CL can be used to compare the style of nixpkgs-fmt against other
formatters (nixpkgs, alejandra).

Change-Id: I87c6abff6bcb546b02ead15ad0405f81e01b6d9e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4397
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Reviewed-by: wpcarro <wpcarro@gmail.com>
Reviewed-by: Profpatsch <mail@profpatsch.de>
Reviewed-by: kanepyork <rikingcoding@gmail.com>
Reviewed-by: tazjin <tazjin@tvl.su>
Reviewed-by: cynthia <cynthia@tvl.fyi>
Reviewed-by: edef <edef@edef.eu>
Reviewed-by: eta <tvl@eta.st>
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'users/grfn/xanthous/default.nix')
-rw-r--r--users/grfn/xanthous/default.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/users/grfn/xanthous/default.nix b/users/grfn/xanthous/default.nix
index c0eca446c9..e8a1eb14eb 100644
--- a/users/grfn/xanthous/default.nix
+++ b/users/grfn/xanthous/default.nix
@@ -1,6 +1,7 @@
-{ depot ? (import ../../../. {})
+{ depot ? (import ../../../. { })
 , pkgs ? depot.third_party.nixpkgs
-, ... }:
+, ...
+}:
 
 let
   ignore = depot.third_party.gitignoreSource.gitignoreFilter ./.;
@@ -11,7 +12,7 @@ let
       !(type == "directory" && builtins.baseNameOf path == "server")
       && !(type == "directory" && builtins.baseNameOf path == "docs")
       && (ignore path type
-          || builtins.baseNameOf path == "package.yaml");
+      || builtins.baseNameOf path == "package.yaml");
   };
   # generated by cabal2nix
   basePkg = pkgs.haskellPackages.callPackage ./pkg.nix { };
@@ -22,5 +23,5 @@ pkgs.haskell.lib.overrideCabal basePkg (default: {
   version = "canon";
   configureFlags = [
     "--ghc-option=-Wall --ghc-option=-Werror"
-  ] ++ (default.configureFlags or []);
+  ] ++ (default.configureFlags or [ ]);
 })