about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/games.nix
diff options
context:
space:
mode:
authorAspen Smith <grfn@gws.fyi>2024-02-12T03·00-0500
committerclbot <clbot@tvl.fyi>2024-02-14T19·37+0000
commit82ecd61f5c699cf3af6c4eadf47a1c52b1d696c6 (patch)
tree429c5e078528000591742ec3211bc768ae913a78 /users/grfn/system/home/modules/games.nix
parent0ba476a4266015f278f18d74094299de74a5a111 (diff)
chore(users): grfn -> aspen r/7511
Change-Id: I6c6847fac56f0a9a1a2209792e00a3aec5e672b9
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10809
Autosubmit: aspen <root@gws.fyi>
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'users/grfn/system/home/modules/games.nix')
-rw-r--r--users/grfn/system/home/modules/games.nix61
1 files changed, 0 insertions, 61 deletions
diff --git a/users/grfn/system/home/modules/games.nix b/users/grfn/system/home/modules/games.nix
deleted file mode 100644
index 5e28003892..0000000000
--- a/users/grfn/system/home/modules/games.nix
+++ /dev/null
@@ -1,61 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with pkgs;
-with lib;
-
-let
-
-  df-orig = dwarf-fortress-packages.dwarf-fortress-original;
-
-  df-full = (dwarf-fortress-packages.dwarf-fortress-full.override {
-    theme = null;
-    enableIntro = false;
-    enableFPS = true;
-    enableDFHack = true;
-  });
-
-  init = runCommand "init.txt" { } ''
-    substitute "${df-orig}/data/init/init.txt" $out \
-      --replace "[INTRO:YES]" "[INTRO:NO]" \
-      --replace "[VOLUME:255]" "[VOLUME:0]" \
-      --replace "[FPS:NO]" "[FPS:YES]"
-  '';
-
-  d_init = runCommand "d_init.txt" { } ''
-    substitute "${df-orig}/data/init/d_init.txt" $out \
-      --replace "[AUTOSAVE:NONE]" "[AUTOSAVE:SEASONAL]" \
-      --replace "[AUTOSAVE_PAUSE:NO]" "[AUTOSAVE_PAUSE:YES]" \
-      --replace "[INITIAL_SAVE:NO]" "[INITIAL_SAVE:YES]" \
-      --replace "[EMBARK_WARNING_ALWAYS:NO]" "[EMBARK_WARNING_ALWAYS:YES]" \
-      --replace "[VARIED_GROUND_TILES:YES]" "[VARIED_GROUND_TILES:NO]" \
-      --replace "[SHOW_FLOW_AMOUNTS:NO]" "[SHOW_FLOW_AMOUNTS:YES]"
-  '';
-
-  df = runCommand "dwarf-fortress" { } ''
-    mkdir -p $out/bin
-    sed \
-      -e '4icp -f ${init} "$DF_DIR/data/init/init.txt"' \
-      -e '4icp -f ${d_init} "$DF_DIR/data/init/d_init.txt"' \
-      < "${df-full}/bin/dwarf-fortress" >"$out/bin/dwarf-fortress"
-
-    shopt -s extglob
-    ln -s ${df-full}/bin/!(dwarf-fortress) $out/bin
-
-    chmod +x $out/bin/dwarf-fortress
-  '';
-
-in
-mkMerge [
-  {
-    home.packages = [
-      crawl
-      xonotic
-    ];
-  }
-  (mkIf stdenv.isLinux {
-    home.packages = [
-      df
-      prismlauncher
-    ];
-  })
-]