about summary refs log tree commit diff
path: root/users/glittershark/system/system/modules/desktop.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-09-30T03·42-0400
committerglittershark <grfn@gws.fyi>2020-09-30T03·49+0000
commit3fc1143a04da49a92c3663813c6a0c1e8ccd477f (patch)
treec663dd489e4e0e1b2b090bf103865e3cee865c98 /users/glittershark/system/system/modules/desktop.nix
parent734d07b864df7ef8293a73266ed5bee76b9d523f (diff)
feat(gs/system): Init mugwump r/1831
Init the config for mugwump, a NUC that I bought from ncl and which I'm
going to use as a simple home server and ssh bastion box. Since this is
the first time I've set up a server using my nixos config, this also
moves a bunch of desktop (xserver, audio, etc.) related config out of
modules/common.nix and into a new modules/desktop.nix.

Coming soon: nixos-rebuild switch --target, but in the depot!

Change-Id: I67bd5ba6e3c26f80f77058af186fd41cc245d5d2
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2016
Reviewed-by: glittershark <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/glittershark/system/system/modules/desktop.nix')
-rw-r--r--users/glittershark/system/system/modules/desktop.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/users/glittershark/system/system/modules/desktop.nix b/users/glittershark/system/system/modules/desktop.nix
new file mode 100644
index 0000000000..dc2847a779
--- /dev/null
+++ b/users/glittershark/system/system/modules/desktop.nix
@@ -0,0 +1,25 @@
+{ config, lib, pkgs, ... }:
+
+{
+  imports = [
+    ./xserver.nix
+    ./fonts.nix
+    ./sound.nix
+    ./kernel.nix
+  ];
+
+  programs.nm-applet.enable = true;
+
+  users.users.grfn.extraGroups = [
+    "audio"
+    "video"
+  ];
+
+  services.geoclue2.enable = true;
+
+  powerManagement = {
+    enable = true;
+    cpuFreqGovernor = lib.mkDefault "powersave";
+    powertop.enable = true;
+  };
+}