about summary refs log tree commit diff
path: root/users/glittershark/system/system/modules/common.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-10-23T15·11-0400
committerglittershark <grfn@gws.fyi>2020-10-23T15·23+0000
commitf9125971c295b99180b8bfb455cede6ae55bc195 (patch)
tree2344c9eb5b8736de38a2ad0610abb2dc3752a3ad /users/glittershark/system/system/modules/common.nix
parentf13e88ab071716537e1da14379c4853441c57fa2 (diff)
feat(gs/system): Only enable remote builders on chupacabra r/1857
Don't enable whitby+nixbuild as remote builders on every machine (eg not
mugwump), only chupacabra

Change-Id: I8aa8f20d76da4ec0d8caa64ef04697b7e76cbc03
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2058
Reviewed-by: glittershark <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/glittershark/system/system/modules/common.nix')
-rw-r--r--users/glittershark/system/system/modules/common.nix22
1 files changed, 1 insertions, 21 deletions
diff --git a/users/glittershark/system/system/modules/common.nix b/users/glittershark/system/system/modules/common.nix
index ee7c8fd5fe..711f686d8d 100644
--- a/users/glittershark/system/system/modules/common.nix
+++ b/users/glittershark/system/system/modules/common.nix
@@ -69,31 +69,11 @@ with lib;
   nix = {
     trustedUsers = [ "grfn" ];
     autoOptimiseStore = true;
-
-    buildMachines = [{
-      hostName = "172.16.0.3";
-      sshUser = "griffin";
-      sshKey = "/home/grfn/.ssh/id_rsa";
-      system = "x86_64-darwin";
-      maxJobs = 4;
-    } {
-      hostName = "172.16.0.4";
-      sshUser = "griffin";
-      sshKey = "/home/grfn/.ssh/id_rsa";
-      system = "x86_64-darwin";
-      maxJobs = 8; # 16 cpus
-    } {
-      hostName = "eu.nixbuild.net";
-      system = "x86_64-linux";
-      maxJobs = 100;
-      supportedFeatures = [ "benchmark" "big-parallel" ];
-    }];
-
     distributedBuilds = true;
 
     gc = {
       automatic = true;
-      dates = "weekly";
+      dates = mkDefault "weekly";
       options = "--delete-older-than 30d";
     };
   };