about summary refs log tree commit diff
path: root/users/glittershark/system/system/modules/common.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-10-13T03·30-0400
committerglittershark <grfn@gws.fyi>2020-10-13T03·35+0000
commitdf77855beb23fd4c74c4d6ae930dcd755b164416 (patch)
treeaef37ba9b1a4a5f3ef680c173a92ac3fb6a71b60 /users/glittershark/system/system/modules/common.nix
parent963088aff63fd474fa44fa7a748accfdb85a0f85 (diff)
feat(gs/system): Setup for yubikey r/1849
Install some packages and enable the necessary services + udev stuff to
make yubikeys usable

Change-Id: I8aee8a8b06895880c8195f02fb57b1216a5fdffc
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2049
Reviewed-by: glittershark <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/glittershark/system/system/modules/common.nix')
-rw-r--r--users/glittershark/system/system/modules/common.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/users/glittershark/system/system/modules/common.nix b/users/glittershark/system/system/modules/common.nix
index c3a339ef3b..ee7c8fd5fe 100644
--- a/users/glittershark/system/system/modules/common.nix
+++ b/users/glittershark/system/system/modules/common.nix
@@ -97,4 +97,10 @@ with lib;
       options = "--delete-older-than 30d";
     };
   };
+
+  services.udev.packages = with pkgs; [
+    yubikey-personalization
+  ];
+
+  services.pcscd.enable = true;
 }