about summary refs log tree commit diff
path: root/users/glittershark/system/system/modules/common.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-07-03T00·02-0400
committerglittershark <grfn@gws.fyi>2020-07-03T00·07+0000
commit6cabc4289c13776aa61ebcb81f15db830c63ebf7 (patch)
tree0cf3e82098339a1cea0ea649f6182db601857165 /users/glittershark/system/system/modules/common.nix
parent5c96703765ba68b10f0bba8200d801e1ed09fe5e (diff)
feat(gs:system): steal tazjin's rebuilder script r/1181
gonna use this instead of nixos-rebuild switch, in part to get away from
global nixpkgs pins.

Change-Id: I46e2951660465790adfdf75e6e3413b5c2dfd7c7
Reviewed-on: https://cl.tvl.fyi/c/depot/+/886
Reviewed-by: glittershark <grfn@gws.fyi>
Reviewed-by: BuildkiteCI
Tested-by: BuildkiteCI
Diffstat (limited to 'users/glittershark/system/system/modules/common.nix')
-rw-r--r--users/glittershark/system/system/modules/common.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/users/glittershark/system/system/modules/common.nix b/users/glittershark/system/system/modules/common.nix
index c7f5055a82..1d578e36f6 100644
--- a/users/glittershark/system/system/modules/common.nix
+++ b/users/glittershark/system/system/modules/common.nix
@@ -1,5 +1,11 @@
 { config, lib, pkgs, ... }:
 
+let
+
+  depot = import ../../../../.. {};
+
+in
+
 {
   imports =
     [
@@ -35,6 +41,7 @@
     libnotify
     file
     lm_sensors
+    depot.users.glittershark.system.system.rebuilder
   ];
 
   # Some programs need SUID wrappers, can be configured further or are