about summary refs log tree commit diff
path: root/users/glittershark/system/system/machines/chupacabra.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-10-27T21·26-0400
committerglittershark <grfn@gws.fyi>2020-10-27T21·47+0000
commited9909527cc13222b2dcd1ad4be4da05ab2600c4 (patch)
treed3ca65bc3cd7e4095411680d822f49a0de7c8539 /users/glittershark/system/system/machines/chupacabra.nix
parent98ed3c56db917da82f7c450c0256024f52235098 (diff)
refactor(gs/system): Prefer dobharchu over cerberus r/1865
This machine is significantly faster. Also, drop nixbuild, since the
transfer speed is too slow to make it worth it.

Change-Id: Ic14ef96e03a81dc429e4b4fec961c891dbb4b2b9
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2066
Reviewed-by: glittershark <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/glittershark/system/system/machines/chupacabra.nix')
-rw-r--r--users/glittershark/system/system/machines/chupacabra.nix34
1 files changed, 16 insertions, 18 deletions
diff --git a/users/glittershark/system/system/machines/chupacabra.nix b/users/glittershark/system/system/machines/chupacabra.nix
index 4e0f9fff01..38ec11e977 100644
--- a/users/glittershark/system/system/machines/chupacabra.nix
+++ b/users/glittershark/system/system/machines/chupacabra.nix
@@ -118,23 +118,21 @@
     maxJobs = lib.mkDefault 12;
     binaryCaches = [ "ssh://grfn@172.16.0.5" ];
     trustedBinaryCaches = [ "ssh://grfn@172.16.0.5" ];
-    buildMachines = [{
-      hostName = "172.16.0.3";
-      sshUser = "griffin";
-      sshKey = "/home/grfn/.ssh/id_rsa";
-      system = "x86_64-darwin";
-      maxJobs = 4;
-    } {
-      hostName = "172.16.0.4";
-      sshUser = "griffin";
-      sshKey = "/home/grfn/.ssh/id_rsa";
-      system = "x86_64-darwin";
-      maxJobs = 8; # 16 cpus
-    } {
-      hostName = "eu.nixbuild.net";
-      system = "x86_64-linux";
-      maxJobs = 100;
-      supportedFeatures = [ "benchmark" "big-parallel" ];
-    }];
+    buildMachines = [
+      {
+        hostName = "172.16.0.4";
+        sshUser = "griffin";
+        sshKey = "/home/grfn/.ssh/id_rsa";
+        system = "x86_64-darwin";
+        maxJobs = 8; # 16 cpus
+      }
+      {
+        hostName = "172.16.0.3";
+        sshUser = "griffin";
+        sshKey = "/home/grfn/.ssh/id_rsa";
+        system = "x86_64-darwin";
+        maxJobs = 4;
+      }
+    ];
   };
 }