about summary refs log tree commit diff
path: root/users/glittershark/system/system/machines/chupacabra.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-09-30T03·42-0400
committerglittershark <grfn@gws.fyi>2020-09-30T03·49+0000
commit3fc1143a04da49a92c3663813c6a0c1e8ccd477f (patch)
treec663dd489e4e0e1b2b090bf103865e3cee865c98 /users/glittershark/system/system/machines/chupacabra.nix
parent734d07b864df7ef8293a73266ed5bee76b9d523f (diff)
feat(gs/system): Init mugwump r/1831
Init the config for mugwump, a NUC that I bought from ncl and which I'm
going to use as a simple home server and ssh bastion box. Since this is
the first time I've set up a server using my nixos config, this also
moves a bunch of desktop (xserver, audio, etc.) related config out of
modules/common.nix and into a new modules/desktop.nix.

Coming soon: nixos-rebuild switch --target, but in the depot!

Change-Id: I67bd5ba6e3c26f80f77058af186fd41cc245d5d2
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2016
Reviewed-by: glittershark <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/glittershark/system/system/machines/chupacabra.nix')
-rw-r--r--users/glittershark/system/system/machines/chupacabra.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/users/glittershark/system/system/machines/chupacabra.nix b/users/glittershark/system/system/machines/chupacabra.nix
index 5d94143096..242c286560 100644
--- a/users/glittershark/system/system/machines/chupacabra.nix
+++ b/users/glittershark/system/system/machines/chupacabra.nix
@@ -7,6 +7,7 @@
     ../modules/tvl.nix
     ../modules/urbint.nix
     ../modules/fcitx.nix
+    ../modules/rtlsdr.nix
     ../../../../../ops/nixos/v4l2loopback.nix
   ];
 
@@ -101,4 +102,15 @@
     libvdpau-va-gl
     intel-media-driver
   ];
+
+  services.udev.extraRules = ''
+    # UDEV rules for Teensy USB devices
+    ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", ENV{ID_MM_DEVICE_IGNORE}="1"
+    ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789A]?", ENV{MTP_NO_PROBE}="1"
+    SUBSYSTEMS=="usb", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789ABCD]?", MODE:="0666"
+    KERNEL=="ttyACM*", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", MODE:="0666"
+  '';
+
+  # Necessary to get steam working
+  hardware.opengl.driSupport32Bit = true;
 }