about summary refs log tree commit diff
path: root/users/glittershark/system/system/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-12-01T16·59-0500
committerglittershark <grfn@gws.fyi>2020-12-14T18·18+0000
commitcdedcc6238652599534b65f98b9422029ed05368 (patch)
tree6bd140abd3abfcbd812c0f316d08f5f4bb1f70bf /users/glittershark/system/system/default.nix
parentea936e0a78223c02d6e56954c60cf4a29b5e2983 (diff)
feat(gs/system): Setup fingerprint scanner r/1996
This is kinda nifty

Change-Id: I1b9a6762a5349974f539d2c4938a2b3dcdf488ad
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2219
Reviewed-by: glittershark <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/glittershark/system/system/default.nix')
-rw-r--r--users/glittershark/system/system/default.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/users/glittershark/system/system/default.nix b/users/glittershark/system/system/default.nix
index a9eb4a130a..174ccfb360 100644
--- a/users/glittershark/system/system/default.nix
+++ b/users/glittershark/system/system/default.nix
@@ -16,7 +16,13 @@ rec {
   yeren = import ./machines/yeren.nix;
 
   yerenSystem = (pkgs.nixos {
-    configuration = yeren;
+    configuration = { ... }: {
+      imports = [
+        ./machines/yeren.nix
+        "${depot.depotPath}/ops/nixos/depot.nix"
+      ];
+      inherit depot;
+    };
   }).system;
 
   iso = import ./iso.nix args;