about summary refs log tree commit diff
path: root/users/glittershark/system/home/modules/email.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-06-16T00·02+0100
committerVincent Ambo <mail@tazj.in>2020-06-16T00·02+0100
commit81564185e951f69d490be8f5ad76e8ea642b5dde (patch)
treec27cd8a5bb922f710ff7da4b2942d2db09a95376 /users/glittershark/system/home/modules/email.nix
parent85d82a9dc262bffa87423f595f7e957c42713798 (diff)
parent3b174300ae60f63f50427cde3bfd680fd3043c3a (diff)
Add 'users/glittershark/system/' from commit '3b174300ae60f63f50427cde3bfd680fd3043c3a' r/975
git-subtree-dir: users/glittershark/system
git-subtree-mainline: 85d82a9dc262bffa87423f595f7e957c42713798
git-subtree-split: 3b174300ae60f63f50427cde3bfd680fd3043c3a
Diffstat (limited to 'users/glittershark/system/home/modules/email.nix')
-rw-r--r--users/glittershark/system/home/modules/email.nix54
1 files changed, 54 insertions, 0 deletions
diff --git a/users/glittershark/system/home/modules/email.nix b/users/glittershark/system/home/modules/email.nix
new file mode 100644
index 0000000000..80c5385e69
--- /dev/null
+++ b/users/glittershark/system/home/modules/email.nix
@@ -0,0 +1,54 @@
+{ pkgs, ... }:
+{
+  # programs.mbsync.enable = true;
+  programs.lieer.enable = true;
+  programs.notmuch.enable = true;
+  services.lieer.enable = true;
+  programs.msmtp.enable = true;
+
+  home.packages = with pkgs; [
+    mu
+    msmtp
+  ];
+
+  accounts.email.maildirBasePath = "mail";
+  accounts.email.accounts =
+    let
+      mkAccount = params@{ passEntry, ... }: {
+        realName = "Griffin Smith";
+        passwordCommand = "pass ${passEntry}";
+
+        flavor = "gmail.com";
+
+        imapnotify = {
+          enable = true;
+          boxes = [ "Inbox" ];
+        };
+
+        gpg = {
+          key = "0F11A989879E8BBBFDC1E23644EF5B5E861C09A7";
+          signByDefault = true;
+        };
+
+        # mbsync.enable = true;
+        notmuch.enable = true;
+        lieer = {
+          enable = true;
+          sync.enable = true;
+        };
+        msmtp.enable = true;
+      } // builtins.removeAttrs params ["passEntry"];
+    in {
+      work = mkAccount {
+        primary = true;
+        address = "griffin@urbint.com";
+        aliases = [ "grfn@urbint.com" ];
+        passEntry = "urbint/msmtp-app-password";
+      };
+
+      personal = mkAccount {
+        address = "root@gws.fyi";
+        passEntry = "root-gws-msmtp";
+      };
+    };
+}