about summary refs log tree commit diff
path: root/users/glittershark/system/home/modules/development.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-11-25T14·59-0500
committerglittershark <grfn@gws.fyi>2020-11-25T15·06+0000
commit29ea6b9408446f0c033726fd7bb07449ab37d1ee (patch)
tree9a3ad6c1d6af2e1f42c914357991433547bfb0b8 /users/glittershark/system/home/modules/development.nix
parentc56f402383491ee2841ea64edf2022ba361d0b87 (diff)
feat(glittershark): Get everything working on Darwin r/1917
Update everything in home-manager to properly work on darwin (including
adding dobharchu as a top-level attribute from
//users/glittershark/home) and also fix font faces and sizes in emacs
config

Change-Id: Ica889dd212876030d5c2a916a71d8b614e6964f1
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2147
Reviewed-by: glittershark <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/glittershark/system/home/modules/development.nix')
-rw-r--r--users/glittershark/system/home/modules/development.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/users/glittershark/system/home/modules/development.nix b/users/glittershark/system/home/modules/development.nix
index 1fe9381be5..3056f8547a 100644
--- a/users/glittershark/system/home/modules/development.nix
+++ b/users/glittershark/system/home/modules/development.nix
@@ -21,7 +21,7 @@ let
     };
 
     vendorSha256 = "1a5fx6mrv30cl46kswicd8lf5i5shn1fykchvbnbhdpgxhbz6qi4";
-    deleteVendor = true;
+    deleteVendor = pkgs.stdenv.isLinux;
   };
 
 in
@@ -52,8 +52,6 @@ with lib;
 
     gdb
     lldb
-    valgrind
-    rr
     hyperfine
 
     clj2nix
@@ -63,7 +61,10 @@ with lib;
     pg-dump-upsert
 
     config.lib.depot.third_party.clang-tools
-  ]; # ++ optional (stdenv.isLinux) julia;
+  ] ++ optionals (stdenv.isLinux) [
+    valgrind
+    rr
+  ];
 
   programs.git = {
     enable = true;