about summary refs log tree commit diff
path: root/users/glittershark/owothia/packageSet.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2021-03-26T00·51+0100
committersterni <sternenseemann@systemli.org>2021-03-26T01·46+0000
commita040c55d35e41e99c4d6ed95483a7697e14ebdf5 (patch)
tree32d0c984bce73eb372a30b76a25976a9fab7c3f3 /users/glittershark/owothia/packageSet.nix
parent3a49e4f4bf23ab2c2bc59a7574cb8dfe2f07067d (diff)
chore(users/gs/owothia): remove unnecessary overrides, simplify r/2331
* chatter and its dependencies have been fixed in upstream
  haskellPackages, so we can get rid of the packageSet.nix expression:
  https://github.com/NixOS/nixpkgs/pull/116803

* Merged default.nix and pkg.nix into one expression and use
  callCabal2nix instead of emulating it with nested imports.

* Minor refactor of shell.nix and remove haskell-language-server
  until we've redone it or replaced it with the upstream one as now the
  GHC versions are out of sync: hls is built with 8.8.4, but
  haskellPackages uses 8.10.4

Change-Id: Ie75eaa93ba8bd79e749e2442fb28c855b8a15a1d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2661
Tested-by: BuildkiteCI
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'users/glittershark/owothia/packageSet.nix')
-rw-r--r--users/glittershark/owothia/packageSet.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/users/glittershark/owothia/packageSet.nix b/users/glittershark/owothia/packageSet.nix
deleted file mode 100644
index b4742b6ae6..0000000000
--- a/users/glittershark/owothia/packageSet.nix
+++ /dev/null
@@ -1,22 +0,0 @@
-{ pkgs ? (import ../../../. {}).third_party, ... }:
-
-let
-
-  hlib = pkgs.haskell.lib;
-
-in
-
-# overlay can be removed when this is in our pin:
-# https://github.com/NixOS/nixpkgs/pull/116803
-pkgs.haskellPackages.extend (self: super: {
-  regex-tdfa-text = hlib.doJailbreak
-    (hlib.appendPatch
-      super.regex-tdfa-text
-      ./regex-tdfa-text.patch
-    );
-
-  fullstop = hlib.dontCheck super.fullstop;
-
-  chatter = hlib.doJailbreak
-    (hlib.dontCheck (hlib.appendPatch super.chatter ./chatter.patch));
-})