about summary refs log tree commit diff
path: root/users/glittershark/owothia/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2021-03-26T00·51+0100
committersterni <sternenseemann@systemli.org>2021-03-26T01·46+0000
commita040c55d35e41e99c4d6ed95483a7697e14ebdf5 (patch)
tree32d0c984bce73eb372a30b76a25976a9fab7c3f3 /users/glittershark/owothia/default.nix
parent3a49e4f4bf23ab2c2bc59a7574cb8dfe2f07067d (diff)
chore(users/gs/owothia): remove unnecessary overrides, simplify r/2331
* chatter and its dependencies have been fixed in upstream
  haskellPackages, so we can get rid of the packageSet.nix expression:
  https://github.com/NixOS/nixpkgs/pull/116803

* Merged default.nix and pkg.nix into one expression and use
  callCabal2nix instead of emulating it with nested imports.

* Minor refactor of shell.nix and remove haskell-language-server
  until we've redone it or replaced it with the upstream one as now the
  GHC versions are out of sync: hls is built with 8.8.4, but
  haskellPackages uses 8.10.4

Change-Id: Ie75eaa93ba8bd79e749e2442fb28c855b8a15a1d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2661
Tested-by: BuildkiteCI
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'users/glittershark/owothia/default.nix')
-rw-r--r--users/glittershark/owothia/default.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/users/glittershark/owothia/default.nix b/users/glittershark/owothia/default.nix
index 2a1b37800b..171bb36689 100644
--- a/users/glittershark/owothia/default.nix
+++ b/users/glittershark/owothia/default.nix
@@ -1,6 +1,4 @@
-{ pkgs ? (import ../../../. {}).third_party
-, lib ? pkgs.lib
-, ...
-}:
+{ pkgs ? (import ../../../. {}).third_party, ... }:
 
-(import ./packageSet.nix {}).callPackage (import ./pkg.nix { inherit pkgs; }) {}
+pkgs.haskellPackages.callCabal2nix "owothia"
+  (pkgs.gitignoreSource ./.) { }