about summary refs log tree commit diff
path: root/users/glittershark/gws.fyi/orgExportHTML.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-06-16T02·24-0400
committerglittershark <grfn@gws.fyi>2020-06-16T02·34+0000
commite77b2b8f120577125c9ffcfaf2f62bad0955c7fb (patch)
tree0a61ce49aa28972f85bd6d0e9fbf0168285ca554 /users/glittershark/gws.fyi/orgExportHTML.nix
parentb570e4c7cf5da0e3a95b79ef5ded3da936cfffd1 (diff)
feat(gws.fyi): Build from org + integrate with readTree r/986
Build from org via emacs --batch, and update all the top-level
definitions to make things work nicely with readTree.

Change-Id: If0ac49c1d264856392e29b9e7b155641d865525b
Reviewed-on: https://cl.tvl.fyi/c/depot/+/400
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'users/glittershark/gws.fyi/orgExportHTML.nix')
-rw-r--r--users/glittershark/gws.fyi/orgExportHTML.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/users/glittershark/gws.fyi/orgExportHTML.nix b/users/glittershark/gws.fyi/orgExportHTML.nix
new file mode 100644
index 0000000000..b37be10045
--- /dev/null
+++ b/users/glittershark/gws.fyi/orgExportHTML.nix
@@ -0,0 +1,45 @@
+{ pkgs, ... }:
+
+with pkgs;
+with lib;
+
+let
+
+  emacs-nixpkgs =
+    (import <nixpkgs> {
+      overlays = [(import (builtins.fetchTarball {
+        url = "https://github.com/nix-community/emacs-overlay/archive/54afb061bdd12c61bbfcc13bad98b7a3aab7d8d3.tar.gz";
+        sha256 = "0hrbg65d5h0cb0nky7a46md7vlvhajq1hf0328l2f7ln9hznqz6j";
+      }))];
+    });
+
+  emacs = (emacs-nixpkgs.emacsPackagesFor emacs-nixpkgs.emacsUnstable)
+    .emacsWithPackages (p: with p; [
+      org
+    ]);
+
+in
+
+src:
+
+let
+
+  outName =
+    let bn = builtins.baseNameOf src;
+        filename = elemAt (splitString "." bn) 0;
+    in filename + ".html";
+
+in
+
+runCommand outName {} ''
+  cp ${src} file.org
+  echo "${emacs}/bin/emacs --batch"
+  ${emacs}/bin/emacs --batch \
+    --load ${./config.el} \
+    --visit file.org \
+    --eval "(progn
+      (require 'org)
+      (org-html-export-to-html))" \
+    --kill
+  cp file.html $out
+''