about summary refs log tree commit diff
path: root/users/glittershark/gws.fyi/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-06-16T02·24-0400
committerglittershark <grfn@gws.fyi>2020-06-16T02·34+0000
commite77b2b8f120577125c9ffcfaf2f62bad0955c7fb (patch)
tree0a61ce49aa28972f85bd6d0e9fbf0168285ca554 /users/glittershark/gws.fyi/default.nix
parentb570e4c7cf5da0e3a95b79ef5ded3da936cfffd1 (diff)
feat(gws.fyi): Build from org + integrate with readTree r/986
Build from org via emacs --batch, and update all the top-level
definitions to make things work nicely with readTree.

Change-Id: If0ac49c1d264856392e29b9e7b155641d865525b
Reviewed-on: https://cl.tvl.fyi/c/depot/+/400
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'users/glittershark/gws.fyi/default.nix')
-rw-r--r--users/glittershark/gws.fyi/default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/users/glittershark/gws.fyi/default.nix b/users/glittershark/gws.fyi/default.nix
index 6cf7c977e6..333f56f7bc 100644
--- a/users/glittershark/gws.fyi/default.nix
+++ b/users/glittershark/gws.fyi/default.nix
@@ -1,12 +1,15 @@
-with import <nixpkgs> {};
+args@{ pkgs, ... }:
+with pkgs;
 let
+  site = import ./site.nix args;
   bucket = "s3://gws.fyi";
   distributionID = "E2ST43JNBH8C64";
   website =
     runCommand "gws.fyi" { } ''
       mkdir -p $out
-      cp ${./index.html} $out/index.html
+      cp ${site.index} $out/index.html
     '';
+
 in writeShellScript "deploy.sh" ''
   ${awscli}/bin/aws s3 sync ${website}/ ${bucket}
   ${awscli}/bin/aws cloudfront create-invalidation \