about summary refs log tree commit diff
path: root/users/glittershark/achilles/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2021-03-19T23·43-0400
committerglittershark <grfn@gws.fyi>2021-03-20T20·20+0000
commitb1c4b84dbac9073e5f4b1dd7c5e0b7f549a32200 (patch)
tree84b982b90d7fcd63ea3952d44c45747723de85d3 /users/glittershark/achilles/default.nix
parentd031ec0234d1b9913667ee87ce9cd9f3e8dfe301 (diff)
chore(gs/achilles): Integrate with the depot build r/2291
Get achilles building in Nix as part of the depot's build tree. This
involved making it work with stable rust, since the depot only exposes
stable rust to sub-packages, which turned out to be fairly
straightforward.

Also adds libffi as a new top-level expose, since it's required to build achilles

Change-Id: I5f6dedb26c0b81ec258aedde1973e74903c07ece
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2612
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: tazjin <mail@tazj.in>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/glittershark/achilles/default.nix')
-rw-r--r--users/glittershark/achilles/default.nix21
1 files changed, 19 insertions, 2 deletions
diff --git a/users/glittershark/achilles/default.nix b/users/glittershark/achilles/default.nix
index 4a72bac2ba..8ce6fda5c1 100644
--- a/users/glittershark/achilles/default.nix
+++ b/users/glittershark/achilles/default.nix
@@ -1,3 +1,20 @@
-# TODO(glittershark): Write the actual default.nix
+{ pkgs, ... }:
 
-_: "nothing to see yet"
+pkgs.naersk.buildPackage {
+  src = ./.;
+
+  buildInputs = with pkgs; [
+    clang_11
+    llvmPackages.llvm
+    llvmPackages.bintools
+    llvmPackages.clang
+    llvmPackages.libclang.lib
+    zlib
+    ncurses
+    libxml2
+    libffi
+    pkgconfig
+  ];
+
+  doCheck = true;
+}