about summary refs log tree commit diff
path: root/users/Profpatsch/tree-sitter.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2021-04-23T20·04+0200
committerProfpatsch <mail@profpatsch.de>2021-04-24T10·23+0000
commiteb41eef6127216543d8b28c9c423ac1be0a4ee24 (patch)
treec01e67c4062711b3623841e8e56791ec8a14edc1 /users/Profpatsch/tree-sitter.nix
parent7e888c3c7bb36f6ab6e83d4a6f6a755ff4156791 (diff)
chore(nix): move rustSimple from users.Profpatsch.writers r/2547
I think it’s solid enough to use in a wider context.

Change-Id: If53e8bbb6b90fa88d73fb42730db470e822ea182
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3055
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'users/Profpatsch/tree-sitter.nix')
-rw-r--r--users/Profpatsch/tree-sitter.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/users/Profpatsch/tree-sitter.nix b/users/Profpatsch/tree-sitter.nix
index 101ee03d4f..1e3f378019 100644
--- a/users/Profpatsch/tree-sitter.nix
+++ b/users/Profpatsch/tree-sitter.nix
@@ -6,7 +6,7 @@ let
       // depot.nix.getBins pkgs.bc [ "bc" ]
       // depot.nix.getBins pkgs.ocamlPackages.sexp [ "sexp" ];
 
-  print-ast = depot.users.Profpatsch.writers.rustSimple {
+  print-ast = depot.nix.writers.rustSimple {
     name = "print-ast";
     dependencies = with depot.third_party.rust-crates; [
       libloading
@@ -58,7 +58,7 @@ let
     };
   };
 
-  watch-file-modified = depot.users.Profpatsch.writers.rustSimple {
+  watch-file-modified = depot.nix.writers.rustSimple {
     name = "watch-file-modified";
     dependencies = [
       depot.third_party.rust-crates.inotify