about summary refs log tree commit diff
path: root/users/Profpatsch/tree-sitter.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2021-04-02T19·59+0200
committersterni <sternenseemann@systemli.org>2021-04-03T22·16+0000
commit0133fdc737286a678fbc46a97810dfb152588c77 (patch)
treec1900a1bb031a5af547d7843e79585a7ea4b8c37 /users/Profpatsch/tree-sitter.nix
parent3e7073f106dba0b97484935347b94b1c11db9b81 (diff)
chore: move all 3p buildRustCrate derivations to //third_party r/2419
Profpatsch and me are basically the only users of
depot.users.Profpatsch.writers.rustSimple*. To pull in the odd
dependency we usually use buildRustCrate which is rather convenient.
However we've picked up the bad habit of inlining these in a let
somewhere instead of managing them in a more central location although
there has been an (unsuccesful) attempt at this in
//users/Profpatsch/rust-crates.nix.

This CL moves all buildRustCrate based derivations into
third_party.rust-crates and deletes any duplicate derivations we have
accumulated in the tree.

Change-Id: I8f68b95ebd546708e9af07dca36d72dba9ca8c77
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2769
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'users/Profpatsch/tree-sitter.nix')
-rw-r--r--users/Profpatsch/tree-sitter.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/users/Profpatsch/tree-sitter.nix b/users/Profpatsch/tree-sitter.nix
index 8fc2a847c6..101ee03d4f 100644
--- a/users/Profpatsch/tree-sitter.nix
+++ b/users/Profpatsch/tree-sitter.nix
@@ -8,7 +8,7 @@ let
 
   print-ast = depot.users.Profpatsch.writers.rustSimple {
     name = "print-ast";
-    dependencies = with depot.users.Profpatsch.rust-crates; [
+    dependencies = with depot.third_party.rust-crates; [
       libloading
       tree-sitter
     ];
@@ -61,7 +61,7 @@ let
   watch-file-modified = depot.users.Profpatsch.writers.rustSimple {
     name = "watch-file-modified";
     dependencies = [
-      depot.users.Profpatsch.rust-crates.inotify
+      depot.third_party.rust-crates.inotify
       depot.users.Profpatsch.netstring.rust-netstring
     ];
   } ''