about summary refs log tree commit diff
path: root/users/Profpatsch/read-http/default.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2021-01-27T11·52+0100
committerProfpatsch <mail@profpatsch.de>2021-01-27T13·41+0000
commit1fb5a17f1430840da4990ffa35a04aca96f06d0a (patch)
tree301090c9dec769bd59dcb185de61fb55bb00acaa /users/Profpatsch/read-http/default.nix
parentf68781da1be5489892b566b050308916b4f58424 (diff)
feat(users/Profpatsch): add read-http r/2150
reads a http request or response from stdin, and parses its headers
into a netencoded record.

Darn rust code took way too long to write.

Change-Id: Ie99faa6d4bbd4996fa4e43fb119a11d85b611c99
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2447
Reviewed-by: Profpatsch <mail@profpatsch.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/Profpatsch/read-http/default.nix')
-rw-r--r--users/Profpatsch/read-http/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/users/Profpatsch/read-http/default.nix b/users/Profpatsch/read-http/default.nix
new file mode 100644
index 0000000000..20f8675b3f
--- /dev/null
+++ b/users/Profpatsch/read-http/default.nix
@@ -0,0 +1,19 @@
+{ depot, pkgs, ... }:
+
+let
+
+  # reads a http request (stdin), and writes all headers to stdout, as netencoded dict
+  read-http = depot.users.Profpatsch.writers.rustSimple {
+    name = "read-http";
+    dependencies = [
+      depot.users.Profpatsch.rust-crates.httparse
+      depot.users.Profpatsch.netencode.netencode-rs
+      depot.users.Profpatsch.arglib.netencode.rust
+    ];
+  } (builtins.readFile ./read-http.rs);
+
+in {
+  inherit
+    read-http
+    ;
+}