about summary refs log tree commit diff
path: root/users/Profpatsch/read-http.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2021-02-06T21·33+0100
committerProfpatsch <mail@profpatsch.de>2021-02-06T21·38+0000
commite207785e1fc78d06381b369c3b71b7e6becdbf80 (patch)
tree4dd97017f89a1a3e6f5e2fe3d20fd2536ec3d050 /users/Profpatsch/read-http.nix
parent7d28f121c7baba31f5bd731de8aff023fa23bdc0 (diff)
feat(users/Profpatsch/{netencode,http-parse}): use HashMap r/2186
`U::Record` is required to be a hash map (later keys should be
ignored), so why not do the hash map immediately.

This surfaced a problem with read-http, because duplicate headers in
http are possible, but before they’d be silently ignored.
Now we merge them into a `U::List` in case, to be handled by
consumers of read-http.

Change-Id: Ifd594916f76e5acf9d08e705e0dec2c10a0081c9
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2490
Tested-by: BuildkiteCI
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'users/Profpatsch/read-http.nix')
-rw-r--r--users/Profpatsch/read-http.nix1
1 files changed, 0 insertions, 1 deletions
diff --git a/users/Profpatsch/read-http.nix b/users/Profpatsch/read-http.nix
index aff1fa8662..614993c457 100644
--- a/users/Profpatsch/read-http.nix
+++ b/users/Profpatsch/read-http.nix
@@ -2,7 +2,6 @@
 
 let
 
-  # reads a http request (stdin), and writes all headers to stdout, as netencoded dict
   read-http = depot.users.Profpatsch.writers.rustSimple {
     name = "read-http";
     dependencies = [