about summary refs log tree commit diff
path: root/users/Profpatsch/nix-home/default.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2022-01-09T13·43+0100
committerProfpatsch <mail@profpatsch.de>2022-01-09T15·38+0000
commitd64b3e9400b578fa47f78054ce77e6c227d08764 (patch)
treeb874d1c7fc494be38aabaebee2775113ddac9168 /users/Profpatsch/nix-home/default.nix
parent71fe30a87c2dd2c7f93fd34f3abd596755f0d016 (diff)
feat(users/Profpatsch/nix-home): set up actual home paths r/3581
Now baba can start using it to populate config files from depot.

It’s not entirely working as expected, if stow finds a symlink dir
coming from a different stow, it won’t know how to split it up, so
some manual intervention is required in the beginning.

Change-Id: Ia2271308bf7994ea42e6d7c81c2f3fd94ddf63f3
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4838
Reviewed-by: Profpatsch <mail@profpatsch.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/Profpatsch/nix-home/default.nix')
-rw-r--r--users/Profpatsch/nix-home/default.nix15
1 files changed, 9 insertions, 6 deletions
diff --git a/users/Profpatsch/nix-home/default.nix b/users/Profpatsch/nix-home/default.nix
index 1369eb5314..cf9ab0d4d4 100644
--- a/users/Profpatsch/nix-home/default.nix
+++ b/users/Profpatsch/nix-home/default.nix
@@ -85,16 +85,19 @@ let
 
 in
 
-# TODO: temp
+# TODO: temp setup
 lib.pipe {} [
   (_: makeStowDir [{
-    stowPackage = "hello";
-    originalDir = pkgs.hello;
+    stowPackage = "scripts";
+    originalDir = pkgs.linkFarm "scripts-farm" [
+        { name = "scripts/ytextr";
+          path = depot.users.Profpatsch.ytextr; }
+      ];
   }])
   (d: runStow {
     stowDir = d;
-    stowPackage = "hello";
-    targetDir = "/home/philip/tmp/stowed";
-    stowDirOriginPath = "/home/philip/tmp/stowOrigin";
+    stowPackage = "scripts";
+    targetDir = "/home/philip";
+    stowDirOriginPath = "/home/philip/.local/share/nix-home/stow-origin";
   })
 ]