about summary refs log tree commit diff
path: root/users/Profpatsch/netencode/default.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2021-01-31T14·47+0100
committerProfpatsch <mail@profpatsch.de>2021-01-31T16·06+0000
commit83634341aa6683e1b96717757557c7d83a89b3fd (patch)
tree8dbea658a13924e26b7dbb262ec8a7dcb7625035 /users/Profpatsch/netencode/default.nix
parentf0579313d31ac7fafe0f05ee55ecb305bc1cbe23 (diff)
feat(users/Profpatsch/execline): add args_for_exec r/2175
`exec_into_args` would just read argv and exec into it, but we want to
be able to write commands which take some positional arguments first.

Thus we split the invocation into `args_for_exec`, which returns the
positional arguments and prog, and then pass prog to `exec_into_args`
when we want to exec eventually (prog is still an iterator at this
point).

Change-Id: I0b180c1a100b96363fe33ba2c42034ed41716b7a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2474
Tested-by: BuildkiteCI
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'users/Profpatsch/netencode/default.nix')
-rw-r--r--users/Profpatsch/netencode/default.nix17
1 files changed, 8 insertions, 9 deletions
diff --git a/users/Profpatsch/netencode/default.nix b/users/Profpatsch/netencode/default.nix
index 99cffc75b6..fb1d2c2ef8 100644
--- a/users/Profpatsch/netencode/default.nix
+++ b/users/Profpatsch/netencode/default.nix
@@ -99,17 +99,16 @@ let
     extern crate netencode;
     extern crate exec_helpers;
     use netencode::dec::{Record, ScalarAsBytes, Decoder, DecodeError};
+
     fn main() {
         let t = netencode::t_from_stdin_or_panic("record-splice-env");
-            match Record::<ScalarAsBytes>::dec(t) {
-                Ok(map) => {
-                    exec_helpers::exec_into_args(
-                        "record-splice-env",
-                        map.iter().map(|(k,v)| (k.as_bytes(), &v[..])
-                    );
-                },
-                Err(DecodeError(err)) => panic!("{}", err),
-            }
+        let (_, prog) = exec_helpers::args_for_exec("record-splice-env", 0);
+        match Record::<ScalarAsBytes>::dec(t) {
+            Ok(map) => {
+                exec_helpers::exec_into_args("record-splice-env", prog, map);
+            },
+            Err(DecodeError(err)) => panic!("{}", err),
+        }
     }
   '';