about summary refs log tree commit diff
path: root/users/Profpatsch/lib.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2021-01-10T20·41+0100
committerProfpatsch <mail@profpatsch.de>2021-01-11T08·58+0000
commit04f91b59575ede2b230c3f563cc163c6014275e0 (patch)
tree61cbf735953a1db47f274bea656e0d46d563d315 /users/Profpatsch/lib.nix
parent2f807d7f141068d2d60676a89213eaa5353ca6e0 (diff)
feat(users/Profpatsch): add script for randomly evaling nixpkgs r/2071
Running this after a codified refactor acts as a good smoke test,
if a big subset of packages is broken or any central packages are
broken, this should find them quite quickly, thanks to randomness™.

Just let it run for a few minutes and check the errors that pop up.

Change-Id: I1505dd31ca25b29254474a15cd6cb71d9743038a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2346
Tested-by: BuildkiteCI
Reviewed-by: Profpatsch <mail@profpatsch.de>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'users/Profpatsch/lib.nix')
-rw-r--r--users/Profpatsch/lib.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/users/Profpatsch/lib.nix b/users/Profpatsch/lib.nix
index 8120a01d5b..69e6f73e40 100644
--- a/users/Profpatsch/lib.nix
+++ b/users/Profpatsch/lib.nix
@@ -12,7 +12,7 @@ let
   ];
 
   eprintf = depot.nix.writeExecline "eprintf" {} [
-    "fdmove" "-c" "1" "2" bins.printf "%s" "$@"
+    "fdmove" "-c" "1" "2" bins.printf "$@"
   ];
 
 in {