about summary refs log tree commit diff
path: root/users/Profpatsch/emacs-tree-sitter-move/shell.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2020-12-19T18·22+0100
committerProfpatsch <mail@profpatsch.de>2021-01-01T19·03+0000
commit806c281b3491b165d01be561f005dada24107363 (patch)
tree3cea1ceae3892dfa648a16c108aac1cfafcf4a07 /users/Profpatsch/emacs-tree-sitter-move/shell.nix
parentc9b985e7bc20c7dc90f14f47f8709864b05c032f (diff)
feat(users/Profpatsch): moving around via the tree-sitter parse tree r/2042
Has a little setup to get the cursor position and map it onto a tree
sitter node. The current node is saved in a cursor variable, and a
highlight overlay marks the range of the current node in the buffer.

Change-Id: I0af56115f928732e993fbefe978a246ca7c757ee
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2258
Reviewed-by: lukegb <lukegb@tvl.fyi>
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: Profpatsch <mail@profpatsch.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/Profpatsch/emacs-tree-sitter-move/shell.nix')
-rw-r--r--users/Profpatsch/emacs-tree-sitter-move/shell.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/users/Profpatsch/emacs-tree-sitter-move/shell.nix b/users/Profpatsch/emacs-tree-sitter-move/shell.nix
new file mode 100644
index 0000000000..81d622ac73
--- /dev/null
+++ b/users/Profpatsch/emacs-tree-sitter-move/shell.nix
@@ -0,0 +1,16 @@
+{ pkgs ? import ../../../third_party {}, ... }:
+let
+  inherit (pkgs) lib;
+
+  treeSitterGrammars = pkgs.runCommandLocal "grammars" {} ''
+    mkdir -p $out/bin
+    ${lib.concatStringsSep "\n"
+      (lib.mapAttrsToList (name: src: "ln -s ${src}/parser $out/bin/${name}.so") pkgs.tree-sitter.builtGrammars)};
+  '';
+
+in pkgs.mkShell {
+  buildInputs = [
+    pkgs.tree-sitter.builtGrammars.python
+  ];
+  TREE_SITTER_GRAMMAR_DIR = treeSitterGrammars;
+}