about summary refs log tree commit diff
path: root/users/Profpatsch/arglib/netencode.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2022-08-20T00·34+0200
committerProfpatsch <mail@profpatsch.de>2022-08-22T12·47+0000
commitfdc5763f5be6c1749cfec1b39e13dfcb414acfb0 (patch)
tree2a9a8e47f2e558a48d6e7d3ddb35f5cf6ae4cdb3 /users/Profpatsch/arglib/netencode.nix
parent0fc16342554d293438a62a96adec4f48dac09d54 (diff)
feat(users/Profpatsch): init haskell arglib-netencode r/4448
Mirrors the rust exec-helpers

Change-Id: I96f211d6545e228b8ae0c1dce4e60e6f6867690c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6117
Tested-by: BuildkiteCI
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'users/Profpatsch/arglib/netencode.nix')
-rw-r--r--users/Profpatsch/arglib/netencode.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/users/Profpatsch/arglib/netencode.nix b/users/Profpatsch/arglib/netencode.nix
index 3f1d121e51..c628d800de 100644
--- a/users/Profpatsch/arglib/netencode.nix
+++ b/users/Profpatsch/arglib/netencode.nix
@@ -36,6 +36,28 @@ let
           t
       }
     '';
+
+    haskell = pkgs.haskellPackages.mkDerivation {
+      pname = "arglib-netencode";
+      version = "0.1.0";
+
+      src = depot.users.Profpatsch.exactSource ./. [
+        ./arglib-netencode.cabal
+        ./ArglibNetencode.hs
+      ];
+
+      libraryHaskellDepends = [
+        depot.users.Profpatsch.my-prelude
+        depot.users.Profpatsch.netencode.netencode-hs
+        depot.users.Profpatsch.execline.exec-helpers-hs
+      ];
+
+      isLibrary = true;
+      license = lib.licenses.mit;
+
+
+    };
+
   };
 
 in