about summary refs log tree commit diff
path: root/users/Profpatsch/arglib/netencode.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2023-01-15T20·20+0100
committerProfpatsch <mail@profpatsch.de>2023-01-15T20·36+0000
commitf627ee84b3a002e8f1fe38d7859860faf7d40be9 (patch)
treed541adcae274bacaf95f690d8908a34c2e9bfa4d /users/Profpatsch/arglib/netencode.nix
parent1a18c25d816298775cafa970c34b7ec41cdf127a (diff)
feat(users/Profpatsch/mailbox-org): add simple request json example r/5661
Adds a simple json quasiquoter thingy.

Json can be sent to the `/mailfilter?action=update` endpoint.

Change-Id: Iba80c2ab69178e431519933c4a01cd68aaa9f637
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7839
Tested-by: BuildkiteCI
Autosubmit: Profpatsch <mail@profpatsch.de>
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'users/Profpatsch/arglib/netencode.nix')
-rw-r--r--users/Profpatsch/arglib/netencode.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/users/Profpatsch/arglib/netencode.nix b/users/Profpatsch/arglib/netencode.nix
index 2b94bd51cf..88bad97a3a 100644
--- a/users/Profpatsch/arglib/netencode.nix
+++ b/users/Profpatsch/arglib/netencode.nix
@@ -5,7 +5,7 @@ let
   # Add the given nix arguments to the program as ARGLIB_NETENCODE envvar
   #
   # Calls `netencode.gen.dwim` on the provided nix args value.
-  with-args = args: prog: depot.nix.writeExecline "${prog.name}-with-args" { } [
+  with-args = name: args: prog: depot.nix.writeExecline "${name}-with-args" { } [
     "export"
     "ARGLIB_NETENCODE"
     (depot.users.Profpatsch.netencode.gen.dwim args)