about summary refs log tree commit diff
path: root/users/Profpatsch/arglib/default.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2021-02-08T02·23+0100
committerProfpatsch <mail@profpatsch.de>2021-02-09T01·36+0000
commit60b79b2d9d07b35496c221ad3651f2d2fee74b21 (patch)
tree0fa7ece086c01d39f3bc81809836090a1d050297 /users/Profpatsch/arglib/default.nix
parent9fe1db6193d512f4a61eff180055f14b7d92579d (diff)
feat(users/Profpatsch/arglib): use exec_helpers for rust r/2192
Change-Id: I3056385eb11e45ae13456f4c47052651ba5fb62f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2496
Tested-by: BuildkiteCI
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'users/Profpatsch/arglib/default.nix')
-rw-r--r--users/Profpatsch/arglib/default.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/users/Profpatsch/arglib/default.nix b/users/Profpatsch/arglib/default.nix
index 4f9f8e4cae..4da2e196db 100644
--- a/users/Profpatsch/arglib/default.nix
+++ b/users/Profpatsch/arglib/default.nix
@@ -5,28 +5,30 @@ let
     rust = depot.users.Profpatsch.writers.rustSimpleLib {
       name = "arglib-netencode";
       dependencies = [
+        depot.users.Profpatsch.execline.exec-helpers
         depot.users.Profpatsch.netencode.netencode-rs
       ];
     } ''
       extern crate netencode;
+      extern crate exec_helpers;
 
       use netencode::{T};
       use std::os::unix::ffi::OsStrExt;
 
-      pub fn arglib_netencode(env: Option<&std::ffi::OsStr>) -> Result<T, String> {
+      pub fn arglib_netencode(prog_name: &str, env: Option<&std::ffi::OsStr>) -> T {
           let env = match env {
               None => std::ffi::OsStr::from_bytes("ARGLIB_NETENCODE".as_bytes()),
               Some(a) => a
           };
           match std::env::var_os(env) {
-              None => Err(format!("could not read args, envvar {} not set", env.to_string_lossy())),
+              None => exec_helpers::die_user_error(prog_name, format!("could not read args, envvar {} not set", env.to_string_lossy())),
               // TODO: good error handling for the different parser errors
               Some(soup) => match netencode::parse::t_t(soup.as_bytes()) {
                   Ok((remainder, t)) => match remainder.is_empty() {
-                      true => Ok(t),
-                      false => Err(format!("there was some unparsed bytes remaining: {:?}", remainder))
+                      true => t,
+                      false => exec_helpers::die_environment_problem(prog_name, format!("arglib: there was some unparsed bytes remaining: {:?}", remainder))
                   },
-                  Err(err) => Err(format!("parsing error: {:?}", err))
+                  Err(err) => exec_helpers::die_environment_problem(prog_name, format!("arglib parsing error: {:?}", err))
               }
           }
       }