about summary refs log tree commit diff
path: root/tvix/verify-lang-tests/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2022-10-23T17·37-0400
committertazjin <tazjin@tvl.su>2022-10-29T10·45+0000
commitd0a836b0e1ee1034144d1e5b71df6ab285c8450e (patch)
tree73fd2ee2803af3d0a1617e7da3769cd5076091dd /tvix/verify-lang-tests/default.nix
parentb8a7dba709436eeb562f8911ae1b5691830d6fd7 (diff)
feat(tvix/eval): Implement comparison for lists r/5221
Lists are compared lexicographically in C++ nix as of [0], and our
updated nix test suites depend on this. This implements comparison of
list values in `Value::nix_cmp` using a very similar algorithm to what
C++ does - similarly to there, this requires passing in the VM so we can
force thunks in the list elements as we go.

[0]: https://github.com/NixOS/nix/commit/09471d2680292af48b2788108de56a8da755d661#

Change-Id: I5d8bb07f90647a1fec83f775243e21af856afbb1
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7070
Autosubmit: grfn <grfn@gws.fyi>
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--tvix/verify-lang-tests/default.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/verify-lang-tests/default.nix b/tvix/verify-lang-tests/default.nix
index e05ef17a85..ca7ea4b348 100644
--- a/tvix/verify-lang-tests/default.nix
+++ b/tvix/verify-lang-tests/default.nix
@@ -53,6 +53,7 @@ let
     "eval-okay-zipAttrsWith.nix" = [ nix ];
     # Comparable lists are not in Nix 2.3
     "eval-okay-sort.nix" = [ nix ];
+    "eval-okay-compare-lists.nix" = [ nix ];
     # getAttrPos gains support for functionArgs-returned sets after 2.3
     "eval-okay-getattrpos-functionargs.nix" = [ nix ];
   };