about summary refs log tree commit diff
path: root/tvix/nix-compat/Cargo.toml
diff options
context:
space:
mode:
authorBrian Olsen <brian@maven-group.org>2024-08-28T13·45+0200
committerclbot <clbot@tvl.fyi>2024-08-28T14·43+0000
commita5fcfd80a16d985bcef7011ad94eab86cc0b4a72 (patch)
tree00d6f3fcea7d4da814eb31dce1bc3a2cef7850dc /tvix/nix-compat/Cargo.toml
parent743407e7abf9cf56274c8c9bcb1edb10d8f943ed (diff)
fix(tvix/nix-compat-derive): Get rid of external feature flag r/8602
The external feature flag was there because I couldn't find a way to
refer to crate and nix-compat with the same name so that the generated
code could be the same.

In essence `use nix_compat::nix_daemon::de::NixDeserialize` is an error
when used inside nix_compat crate.

So my best fix was the external feature flag until I found the solution
used here which also removes the flag completely.

Change-Id: Ia3e89c6c350c3fb22ca87f974a39c21542aae152
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12376
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Autosubmit: Brian Olsen <me@griff.name>
Diffstat (limited to 'tvix/nix-compat/Cargo.toml')
-rw-r--r--tvix/nix-compat/Cargo.toml1
1 files changed, 0 insertions, 1 deletions
diff --git a/tvix/nix-compat/Cargo.toml b/tvix/nix-compat/Cargo.toml
index 87e9b1e6760c..fade4f117a09 100644
--- a/tvix/nix-compat/Cargo.toml
+++ b/tvix/nix-compat/Cargo.toml
@@ -37,7 +37,6 @@ version = "1.6.1"
 [dependencies.nix-compat-derive]
 path = "../nix-compat-derive"
 optional = true
-default-features = false
 
 [dependencies.tokio]
 optional = true