about summary refs log tree commit diff
path: root/tvix/nix-compat/Cargo.toml
diff options
context:
space:
mode:
authorIlan Joselevich <personal@ilanjoselevich.com>2024-08-28T21·42+0300
committerclbot <clbot@tvl.fyi>2024-08-29T11·26+0000
commit2945a359b46862b3da79dec37fa8ccb2f751fa8a (patch)
tree417ef91beb55c07f9e299d5b172163cf740aa3c3 /tvix/nix-compat/Cargo.toml
parent02ee4416260aeb86f39095f6a4e26d3c969f9a9e (diff)
chore(tvix): Bump versions of all compatible deps via cargo upgrade r/8609
This updates all the dependencies and their "minimum" versions in
Cargo.{lock,toml} to the latest compatible version using `cargo-edit`'s
`cargo upgrade` command that will eventually be merged into `cargo
update`.

Change-Id: Iccb2aa4a1c84a0465222244a0bd0cafe2a82e781
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12388
Reviewed-by: flokli <flokli@flokli.de>
Autosubmit: Ilan Joselevich <personal@ilanjoselevich.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/nix-compat/Cargo.toml')
-rw-r--r--tvix/nix-compat/Cargo.toml28
1 files changed, 14 insertions, 14 deletions
diff --git a/tvix/nix-compat/Cargo.toml b/tvix/nix-compat/Cargo.toml
index fade4f117a09..eff15f0f3bd3 100644
--- a/tvix/nix-compat/Cargo.toml
+++ b/tvix/nix-compat/Cargo.toml
@@ -14,25 +14,25 @@ test = []
 default = ["async", "wire", "nix-compat-derive"]
 
 [dependencies]
-bitflags = "2.4.1"
-bstr = { version = "1.6.0", features = ["alloc", "unicode", "serde"] }
+bitflags = "2.6.0"
+bstr = { version = "1.10.0", features = ["alloc", "unicode", "serde"] }
 data-encoding = "2.6.0"
 ed25519 = "2.2.3"
-ed25519-dalek = "2.1.0"
+ed25519-dalek = "2.1.1"
 enum-primitive-derive = "0.3.0"
-glob = "0.3.0"
+glob = "0.3.1"
 mimalloc = "0.1.43"
 nom = "7.1.3"
-num-traits = "0.2.18"
+num-traits = "0.2.19"
 serde = { version = "1.0", features = ["derive"] }
 serde_json = "1.0"
-sha2 = "0.10.6"
-thiserror = "1.0.38"
-tracing = "0.1.37"
+sha2 = "0.10.8"
+thiserror = "1.0.63"
+tracing = "0.1.40"
 
 [dependencies.bytes]
 optional = true
-version = "1.6.1"
+version = "1.7.1"
 
 [dependencies.nix-compat-derive]
 path = "../nix-compat-derive"
@@ -40,25 +40,25 @@ optional = true
 
 [dependencies.tokio]
 optional = true
-version = "1.32.0"
+version = "1.39.3"
 features = ["io-util", "macros"]
 
 [dependencies.pin-project-lite]
 optional = true
-version = "0.2.13"
+version = "0.2.14"
 
 [dev-dependencies]
 criterion = { version = "0.5", features = ["html_reports"] }
 futures = { version = "0.3.30", default-features = false, features = ["executor"] }
 hex-literal = "0.4.1"
-lazy_static = "1.4.0"
+lazy_static = "1.5.0"
 mimalloc = "0.1.43"
 pretty_assertions = "1.4.0"
 rstest = "0.19.0"
 serde_json = "1.0"
 smol_str = "0.2.2"
-tokio-test = "0.4.3"
-zstd = "^0.13.0"
+tokio-test = "0.4.4"
+zstd = "^0.13.2"
 
 [[bench]]
 name = "derivation_parse_aterm"